Kerya techblog

Most Read Posts

  • Gentoo mail (postfix + postfixadmin + dovecot + amavisd-new + roundcube)
  • Zabbix - no such instance currently exists at this oid
  • LVM cant Boot - ALERT /dev/mapper/ubuntu--vg-root does not exist DROPPING to Shell -
  • liquidsoap-1.1.1 gentoo install
  • Laravel manual user register
  • Gentoo: php 5.6.0 + pecl-memcached 2.2.0 install script
  • Zabbix APC Smart UPS monitoring on FreeBSD with snmp
  • Squid 3.4 debian 7 install script
  • Подключение Foxgate S6224-S2 Ubuntu minicom
  • Abills
  • exim+dovecot+postfixadmin+clamav+spamassassin on FreeBSD
  • Openmeetings 2.1.1 Ubuntu 12.04.2 installation
  • libtool version mismatch pecl gentoo
  • Securing NTP
  • FreeBSD 9 ossec setup errors fix
  • fix for - corrupted record for package (pkgdep line without argument), ignoring
  • snmpd less verbose log FreeBSD (Connection from UDP messages)
  • Mikrotik no-ip ddns update script
  • Скопировать права mysql gentoo
  • mysql backup scripts
  1. Вы здесь:  
  2. Home
  • Home
  • Все статьи

systemd-resolved vpn dns servers priority

Подробности
Автор: Kirill

After connecting pptp vpn dns servers recieved from vpn server are listed at the bottom of the list in /etc/resolv.conf and have lowest priority.

To make them have higher priority:

nmcli -p connection modify MY_VPN_CONNECTION ipv4.dns-priority -42

 

found this on:

https://github.com/systemd/systemd/issues/6076

Mikrotik no-ip ddns update script

Подробности
Автор: Kirill
  • mikrotik
  • no-ip

based on https://wiki.mikrotik.com/wiki/Dynamic_DNS_Update_Script_for_No-IP_DNS

:local ddnsuser "<no-ip_username>"
:local ddnspass "<no-ip_pass>"
:local ddnshostname "<no-ip_host.ddns.net>"
:local ddnsinterface "<ddns_iface_name>"
# global variables definition
:global ddnslastip
#local vars definitions
:local ddnsip
#:local ddnsURL "http://dynupdate.no-ip.com/nic/update?hostname=$ddnshostname&myip=$ddnsip"
# base64 encoded string of username:password used # https://www.noip.com/integrate/request
:local auth "Authorization:<base64 encoded string>"
:local useragent "User-Agent:Mikrotik-script <maintainer email>"
:local headers
:set $headers "$auth , $useragent"
:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
:local ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
:if ([ :typeof $ddnsip ] = nil ) do={
:log info ("ServiceDNS: No ip address on $ddnsinterface .")
} else={
:for i from=( [:len $ddnsip] - 1) to=0 do={
:if ( [:pick $ddnsip $i] = "/") do={
:set ddnsip [:pick $ddnsip 0 $i];
}
}
}
:if ($ddnsip != $ddnslastip) do={
:log info ("ServiceDNS: $ddnshostname -> $ddnsip")
:local ddnsURL "http://dynupdate.no-ip.com/nic/update?hostname=$ddnshostname&myip=$ddnsip"

:local response [ /tool fetch url=$ddnsURL http-header-field=$headers as-value output=user ]

if ($response->"status" = "finished") do={
:local data ($response->"data");

:set $ddnslastip $ddnsip
:log info ("$ddnslastip")
:log info "DDNS: Update succeeded."
} else={
:log error "DDNS: Update failed.";
}
} else {
# :log info "DDNS: No IP change.";
} }

glib20 configure error

Подробности
Автор: Kirill

error:

checking for DocBook XSL Stylesheets in XML catalog... not found
checking for DocBook XSL Stylesheets in XML catalog... not found
configure: error: DocBook XSL Stylesheets are required for --enable-man
===> Script "configure" failed unexpectedly.

 

In the config.log file :

configure:28806: checking for DocBook XSL Stylesheets in XML catalog
configure:28809: $XMLCATALOG --noout "$XML_CATALOG_FILE" "http://docbook.sourcef
No entry for SYSTEM http://docbook.sourceforge.net/release/xsl/current/manpages/
No entry for URI http://docbook.sourceforge.net/release/xsl/current/manpages/doc
configure:28812: $? = 4
configure:28818: result: not found
configure:28827: error: DocBook XSL Stylesheets are required for --enable-man

 Same thing for

configure: error: docbook dtd is required for --enable-man

Root of the problem in xml catalog file. Because XML/XSL entry is missing

 

My solution was to add manually XSL entry in /usr/local/share/xml/catalog.ports:

 

# cat /usr/local/share/xml/catalog.ports

<?xml version="1.0"?> <!DOCTYPE catalog PUBLIC "-//OASIS//DTD Entity Resolution XML Catalog V1.0//EN"     "http://www.oasis-open.org/committees/entity/release/1.0/catalog.dtd"> <!-- Created by XML Catalog Manager 2.2 --> <catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog"> <nextCatalog catalog="/usr/local/share/xml/docbook/catalog.xml" /> <nextCatalog catalog="/usr/local/share/xsl/docbook/catalog.xml" /><nextCatalog catalog="/usr/local/share/xml/sdocbook/1.1/dtd/catalog.xml" /> </catalog>

Laravel useful info and links

Подробности
Автор: Kirill
  • laravel

https://www.codementor.io/pardeepkumar905/working-with-thin-controller-and-fat-model-concept-in-laravel-nwl7ljsst

 https://matthewdaly.co.uk/blog/2018/02/18/put-your-laravel-controllers-on-a-diet/

 

  1. Laravel manual user register
  2. zabbix ssl monitoring

Страница 6 из 17

  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10

Search

Older Posts

  • Greenbone Vulnerability Manager (GVM) hacks (63)
  • elasticsearch cluster red status fix due to high watermark (61)
  • ubuntu arrow keys misbehaviour fix (72)
  • icinga IIS monitoring powershell error Get-WmiObject : Invalid namespace "root\WebAdministration" (84)
  • Make user superadmin in zabbix (81)
  • dnf Error: unknown option (111)
  • unpack pfx certificate (used for apache or nginx) (116)
  • mysql audit plugin build script (290)
  • mysql dump one row (95)
  • redmine 5 docker-compose (199)
  • gitlab runner dind docker-compose (143)
  • AWS S3 IAM policy to limit to single sub folder (146)
  • logrotate hints (197)
  • bash script to clean files to required percentage (322)
  • Ansible create LVM and mount (732)

Login Form

  • Забыли пароль?
  • Забыли логин?
  • Регистрация